How to see if your WooCommerce site is TLS compliant

Authorize.net has been notifying it’s merchants of an upcoming TLS requirement. As of February 28, 2018 any merchants running TLS 1.0/1.1 will no longer be able to process sales transactions. All credit card processors are requiring that sites meet these requirements by June 30, 2018. It is VERY important to get upgraded to TLS 1.2 as soon as possible.

TLS 1.2 is a protocol that requires certain server configurations in order for compatibility. Note that TSL 1.2 has nothing to do with your WordPress or plugin installations—it has to do with the configuration of your web server.

How can you check your WooCommerce site for TLS 1.2 compatibility?

It’s not that hard. TLS 1.2 requires a few server requirments that you will need to verify. You can find these from within your WordPress dashboard under WooCommerce > Status. Scroll down to the Server environment section and look for these items:

  1. PHP version: Needs to be 5.6 or higher
  2. cURL version: Needs to be 7.34.0 or higher
  3. OpenSSL version: Needs to be 1.0.1 or higher (you’ll find this with the cURL info)
This server meets the requirements for TLS 1.2

If your settings meet these requirements then you do not need to do anything. If not, you must contact your web host immediately and see if they can upgrade your server. At Cinch, our web servers are already TLS 1.2 complaint. If you’d like to move hosting to us, just drop us a note and we’ll coordinate everything for you. Migrations to our servers are always free.

Leave a Reply

Your email address will not be published. Required fields are marked *

See if Cinch is right for you.

Ask us anything. Seriously. Like, what is the air speed velocity of an unladen swallow?

Start a chat right now

Or go ahead and Sign up now